Sound quality problems


Home Forums General Hardware Corner Sound quality problems

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2879
    mathilya
    Participant

    Salut. Because my microphone is finally doing allright and no noise is emitted by it, I feel like I must explain how did I fix it, but IMHO it is very strange. Prepare for my lecture šŸ˜›

    All settings can be changed in my audio manager software. I have 3 options of “improving” the sound: interference suppression, removing acoustic echo and, the most problematic one, conference mode.

    In conference mode, I can change output amplification from 0 to 10. The official description is: “enlarging mic’s recording range and improving recording quality. Strangely, if I turn off conference mdoe, or set output amp. to 0, no one could hear me. I thought that if I set it to output amp. to 1 or 2, there will be no background noise (as recording range would be smaller). HA HA HA. Not al all! Actually, the lower output amp. was, the faster was sensitivity increasing (up to 100% and that background noise was terrible). So, yesterday I set output amp. to 9 and as I watched Twitch stream, my voice was still acceptable.

    If you still have any ideas for improving sound quality, I would be pleased if you could write them down here. I am using 16bit, 48kHz DVD quality setup. And yeah, sorry for any past noises coming out from my mic, they should not occur anymore šŸ˜‰

    #2885
    mattiejas
    Keymaster

    Nice that you finally found a way around the morphed sounds!

    In general, you’ll lose quality of signal if you amplify a silent digital signal to a louder digital signal. So usually you try to keep the amplitude on the analogue signal as high as possible before it gets converted to a digital signal (unless you have “clipping”, i.e. the digital signal has to be trimmed on load input sounds). That means setting your input amplitude to maximum. If the recording is then too loud compared to other sounds in the system, you can either reduce it a bit directly, or better, use a filter just specifically for that application. For example, you can reduce the input volume directly in discord. I’m not entirely sure but I think it leaves the input amplitude as is and simply reduces the amplitude on the digital signal directly.

    The problem with your microphone appears to be that if you set the “amplitude” very low, maybe it tries to compensate by amplifying the resulting digital signal. I think it tries to be too clever. Or maybe your microphone software is interfering with discord’s algorithm leading to some strange feedback. Best option is just to disable all automated compensation and just set it up manually until it’s right.

    This all said, for my twitch broadcast, I have to add a 4x gain filter into OBS on my microphone input because my microphone is natively rather silent (or because I’m speaking too quietly šŸ™‚ ). For a professional recording that would be a pretty bad thing, but for twitch it’s still good enough. For discord I don’t do any separate amplification and apparently I’m quite clear. Perhaps discord has it’s own “tuning” of the microphone signal, just like Skype. OBS just does what you tell it to do.

    #2994
    mathilya
    Participant

    Wow, I can clearly see that sound topics are familiar to you. Thanks for your opinion, I will carry out some more tests with that mic and I will pick the best setting. Maybe Discord is “changing” my voice, as when I’m using, for example Skype, everything seems fine.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Hardware Corner’ is closed to new topics and replies.